2020年5月10日 • ☕️ 1 min read
English

Gatsbyのマイナーバージョンアップすることを行いました。

2.15.14 -> 2.21.21

バージョンアップした後、gatsby developで起動できなくなりました。

エラーメッセージは:

 ERROR 

There was a problem loading the local develop command. Gatsby may not be installed. Perhaps you need to run "npm install"? Cannot find module './lib'



  Error: Cannot find module './lib'

他のプラグインパッケージとの衝突が原因かと思って、かなりの時間で1個づつバージョンアップしてみたら、最後gatsbyをバージョンアップするときのみエラーが出ました。

しかも、元のバージョンに戻してもエラーが消えません。node_modulesを削除しインストールしなおしたら治りましたが。。

もしかして。。。

そうだ、解決方法はとても簡単

gatsbyが含まれ、全てのパッケージをバージョンアップした後、node_modules削除して、インストールしなおしたら無事に治りました!

yarn upgrade --latest
rm -rf node_modules
yarn

関連投稿

GatsbyにNetlify Formのスパム対策

2020年6月18日

フロントエンドのJavaScript学習資料

2018年10月22日

ThunderMiracle

Blog part of ThunderMiracle.com